Lucid Lynx — Downgrading from PHP 5.3

I hit this bug after the upgrade to PHP 5.3 (which happened with my Kubuntu Upgrade to Lucid Lynx). I read in another bug report that this issue was fixed in the latest snaphshot, so I tried compiling from source – using the latest 5.3 snapshot. This didn’t go well, as I hit a seg fault after installation and after about an hour of playing with gdb, I gave up!
So, I had to downgrade to PHP 5.2 ;(. Now lucid repos have 5.3 and I had no idea what to do. Googled around and came across a solution here. That worked. I just had to make sure that each individual php5 package (php5-dev, php5-memcache, php5-curl, etc,.) was listed in the file like this;

Package: php5
Pin: release a=karmic
Pin-Priority: 991

Package: php5-dev
Pin: release a=karmic
Pin-Priority: 991

Package: php5-curl
Pin: release a=karmic
Pin-Priority: 991

and so on(try to script the generation of the file).

I was very glad that the designers of apt had made this easy for us! I knew yum had priorities but, I wasn’t aware of a similar solution for apt. Everyday you learn something new 😉

One thought on “Lucid Lynx — Downgrading from PHP 5.3”

Leave a Reply

Your email address will not be published. Required fields are marked *